Performance degradation on email

Incident Report for RG System

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2026 - 17:42 CEST

Identified

We encountered a degradation in email delivery. Some delays may be experienced.
Posted Jun 24, 2026 - 16:14 CEST