Slowdown on the infrastructure.
Incident Report for RG System
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 17:55 CET
Investigating
We are currently investigating.
Posted Nov 16, 2021 - 15:41 CET