Delay at sending mail alerts
Incident Report for RG System
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 23:04 CET
Investigating
We are currently investigating this issue.
Posted Nov 28, 2022 - 22:49 CET