LogMeIn "Invalid LogMeIn HostID" outage
Incident Report for RG System
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 16:07 CET
Investigating
We are currently investigating on instabilities from LogMeIn.
Posted Oct 27, 2020 - 11:11 CET
This incident affected: LogMeIn APIs.