Slows on SMS service
Incident Report for RG System
Resolved
The service seems to be running fine now, we're still investigating the root causes for future improvements.
Posted over 1 year ago. Nov 14, 2017 - 17:19 CET
Investigating
We have identified slows on SMS service, we're investigating the reason with our service providers.
Posted over 1 year ago. Nov 14, 2017 - 17:03 CET